MacProでモニタが映らなくなった件

公開:
更新:

起動してもモニタ真っ暗。MacProを起動させるもモニタが映らない。

繋いでいるモニタはMacProを起動させると、自動で電源が入り画面が映るようにしている(シャットダウンで、モニタはスリープ状態になり、完全な電源オフにはしない)。画面真っ暗……、ということは、モニタ故障でなければ、映像の出力信号がきていないということだろうから、問題はMacProにあるはずだ。

これは以前にもあって、そのときはビデオカード(グラフィックボード)が壊れたという判断で交換対応。修理依頼でなくてビデオカードをアップルストアで購入して自分で交換した。でも、それは何年も前のことで、今では交換可能なビデオカードはもう売っていないかもしれない。

調べてみると、やはりアップルストアの扱いはなく、秋葉館オンラインショップに在庫があるくらいだった。ビデオカードが壊れているなら交換するしかないが、もし交換しても直らなかったら出費がもったいないので、本当にそれが壊れているかを確かめたい。

検証

壊れているか確認するには次のどちらかの方法が考えられる。

  1. 完動品のビデオカードと交換してみる
  2. 正常なMacProにそのビデオカードを装着してモニタが映るかどうか確かめる

[1.] は、完動品のビデオカードがあればそもそも困っていないので問題外。今回はできる限りの検証をして、それでも原因が特定できない時は [2.] の方法を試してみようと、MacProを持っている方に検証の手伝いをお願いしていた。

以下の検証手順は、専門家のそれとは違うかもしれませんが、まったく訳が分からない人には手がかりになると思うので、検証した項目とそれで何が確認できるかを書いておきます。少しでも参考になれば幸いです。

モニタに他のMac/PCを繋いで映るか試す
映る。映らない場合はモニタが故障している。→ MacProに問題がある。
モニターケーブルを交換
映る。映らない場合はケーブルに問題あり。→ MacProに問題がある。
ビデオカードの出力ポートを変えてみる(未検証)
出力ポートは DVI, Mini DisplayPortだったが、モニタ側に Mini DisplayPortポートがないので試していない。特定のポートのみ映らないのであれば、その個所が故障している。
MacProに他のモニタを繋いで映るか試す
映らない。→ MacProに問題がある。
起動システムを変えてみる
旧MacProは 複数のHDDを搭載することができるようになっていて、HDDを入れ替えて使えるようにもなっています。予備の起動システムを入れたHDDを用意しているので、これを起動システムにしてMacProを起動。→ モニタは映らない → ソフトウエアが原因ではない。

どうやらMacProに問題があるようで、残りの原因は3通り。

  • ビデオカードが壊れている
  • ロジックボード(マザーボード)が壊れている
  • ほかの何か……

正常なMacProにこのビデオカードを搭載すれば、映らない原因を特定できる。以下は知人のMacProで試そうと思っていたことです。

正常なMacProでも映らない
ビデオカードの故障。ビデオカードを買い換える必要がある。
正常なMacProに装着すると映る
元の MacProのロジックボードが故障している。正常なMacProに搭載されていたビデオカードを元のMacProに装着するとモニタは映らないというのも試せれば証明が完璧。ロジックボードとは Macの主要電子部品が組み込まれている最重要パーツで、通常は手に入らないためMacの買い換えが必要になる。

原因は「ほかの何か……」だった!

あとは知人のMacProを借りて検証するしかないな、ということで一旦、検証作業を終える。翌日、念のため(記録も兼ねて)もう一度検証しておこうと思った。HDDを取り替えたりするために電源ケーブルを外していたのを繋ぎ直し、HDDを一台だけ積んで、MacProを起動させる。

すると、モニタの画面が映った! えっ!? なんということでしょう?という訳で映らなかった理由を探るための検証を始める。

HDDを1台だけ積んで起動させる
モニター映る。なんでや?
HDDを4台積んで起動させる
モニタは映らない。MacProの電源に問題があるのだろうか? HDD × 4台+ビデオカードを動かす電力が供給できていない可能性あり。
HDDを1台に戻して起動
モニタ映る。アップルメニューの「この Mac について」でハードウエア情報を確認するとメモリが 16GBになっている(搭載メモリは 24GB)。メモリ故障も併発か!?
搭載は24GBだが、16GBしか認識していない。
16GB
メモリのライザーカードを上下入れ替え
入れ替えて再起動し、メモリを確認すると24GBになっている。念のためもう一度、入れ替えて再起動しても24GB。メモリの接触不良だった可能性あり。
認識/搭載ともに 24GB
24GB
HDDを4台積んで起動
メモリの不認識が解消されて、他にはハードウエアの不調が見つからなかったので、HDD4台にして起動 → モニタ映る。その後はモニタが映らない現象が起こらない。根本の原因はメモリの接触不良だったのか!?

一晩、電源ケーブルを外しておいたのが良かったのか、ライザーカードを装着し直して(メモリも刺し直した)メモリの接触不良が解消したのか、なにが良かったのか、結局はっきりした原因は分からなかったが、とにかくモニタが映るようになって良かった。

これが何かのトラブルの兆しなのか? 経過から1年以上経っていて新たな問題は起こっていません。

今後、関連しているようなことがあれば追記します。